Application down
Incident Report for Qase
Resolved
This incident has been resolved.
Posted Feb 21, 2022 - 09:34 UTC
Investigating
We are currently investigating this issue
Posted Feb 21, 2022 - 09:33 UTC
This incident affected: API and Application.