Website Unreachable

Incident Report for Qase

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 10:57 UTC

Investigating

Our website is currently not reachable due to an SSL handshake error. Our team is actively investigating the root cause.

Please note that the Qase application, APIs, and reporters are fully operational and not affected.
Posted Sep 16, 2025 - 10:27 UTC
This incident affected: Website.